Avaleht
uus teema   vasta Hinnavaatlus »  Serverid / Andmemassiivid / Tulemüürid »  vajaks abi kahe LAN (subnet?) võrgu sidumisel + NAS jagamine + IP TV märgi kõik teemad loetuks
märgi mitteloetuks
vaata eelmist teemat :: vaata järgmist teemat
Hinnavaatlus :: Foorum :: Uudised :: Ärifoorumid :: HV F1 ennustusvõistlus :: Pangalink :: Telekavad :: HV toote otsing
autor
sõnum Saada viide sõbrale. Teata moderaatorile
otsing:  
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 19.07.2018 11:24 vajaks abi kahe LAN (subnet?) võrgu sidumisel + NAS jagamine + IP TV vasta tsitaadiga

Kuna kaablid olid seal juba paigas ehk WAN / LAN otsad tulevad kappi kokku, kuhu mahtus MikroTik RB750Gr3 Router, siis seda muuta ei saa.

EDIT: Kõik peaks olema ühes võrgus A (all pool on selgitused)


internet -> MikroTik RB750Gr3 Router (tiulemüür)

Ignoreeri ka kursiivis teksti, teema on edasi arenenud

-> võrk A ja võrk B

Võrk A ja RT-AC68U saab IP Mikrotik käest

Võrk B saab IP RT-AC68U käest

Eesmärk oleks seda konfida nii:

1) A näeb B's olevat NAS ja

2) B's olev läpakas (wifi) näeb A olevaid tööjaamu.

3) Võrgus B peab toimima Elion IP TV

4) A ja B peavad saama internetti.



NB! Minu jaoks on see võõras teema. Palun räägi asjast võimalikult lihtsalt ja näidiste abil :)

Eesmärk on Elion IPTV VLAN tööle saada, kus hEx on netis läbi ether1, ja selle ether4 otsas on ASUS, mille LAN4 on digibox.

Manus
võrk
võrk


_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.


viimati muutis TGEgL 09.09.2018 15:22, muudetud 5 korda
tagasi üles
vaata kasutaja infot saada privaatsõnum
mikk36
HV Guru
mikk36

liitunud: 21.02.2004




sõnum 19.07.2018 12:10 vasta tsitaadiga

Keera DHCP server ASUSe karbis kinni ning ühenda Mikrotikist tulev kaabel LAN pesasse.
Lisaboonusena võid seadistada ASUSe karbi LAN IP selliseks, et see oleks samas alamvõrgus Mikrotikiga, erineks Mikrotikist ja ei asuks DHCP alas (võimaliku konflikti vältimiseks).

Selle tulemusena on sul üks suur A võrk vaid järgi.
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 19.07.2018 12:17 vasta tsitaadiga

mikk36 kirjutas:
Keera DHCP server ASUSe karbis kinni ning ühenda Mikrotikist tulev kaabel LAN pesasse.
Lisaboonusena võid seadistada ASUSe karbi LAN IP selliseks, et see oleks samas alamvõrgus Mikrotikiga, erineks Mikrotikist ja ei asuks DHCP alas (võimaliku konflikti vältimiseks).

Selle tulemusena on sul üks suur A võrk vaid järgi.


Näiteks: (muudetud) MikroTik annab aadressid 192.168.2. vahemikus 10-50, Asus on .2 ning TV, NAS ja läpakad >=10?
Kas sain õieti aru?

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.


viimati muutis TGEgL 19.07.2018 16:05, muudetud 1 kord
tagasi üles
vaata kasutaja infot saada privaatsõnum
Outenter
HV vaatleja

liitunud: 06.11.2001




sõnum 19.07.2018 12:22 vasta tsitaadiga

1. Asusel lükka DHCP välja ja tee temast AP
2. Mikrotikul võta pordid Bridget välja ja seadista neile IP´d nii võrgule A kui B. Mõlemal võrgupordil peab vaatama, et oleks proxy-arp
3. Seadista mõlemale võrgule DHCP
4. B võrgus oleva NAS´i ja läpaka IP määra DHCP serveris staatiliseks
5. tee tulemüürireegel mis lubab võrgul A pääseda NASi
6. tee tulemüürireegel mis lubab NASil vastata päringutele võrgust A
7. tee tulemüürireegel mis lubab läpaka läbipääsu võrgust B võrku A
8. tee tulemüürireegel mis lubab võrgus A asuvavatel tööjaamadel vastata võrgus B asuvale läpakale
9. Keela ligipääs võrgust A võrku B
10 Keela ligipääs võrgust B võrku A


Jälgi kindlasti tulemüürireeglite järjekorda

_________________
I was an ateist, until I realized - I am a God
tagasi üles
vaata kasutaja infot saada privaatsõnum
mikk36
HV Guru
mikk36

liitunud: 21.02.2004




sõnum 19.07.2018 12:24 vasta tsitaadiga

Kas on vaja, et võrgud oleks üksteisest lahus ja ligi saadaks ainult teatud asjadele või võivad need kõik ühes suures võrgus olla?
Kui võivad ühes suures võrgus olla, siis pane näiteks ASUSe IP 192.168.2.2 ja Mikrotikis DHCP vahemik 192.168.2.10 - 50.
Sama DHCP küljest saavad IP ka wifiga seadmed, kuna ASUSes on wifi ja LAN sillatud.
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 19.07.2018 15:36 vasta tsitaadiga

@mikk36, ma ei näe hetkel ühtegi põhjust, miks ei võiks see olla üks võrk A, nagu sa välja pakkusid.

@Outenter detailne vastus tekitas mõtte, et äkki peaks aga selle TV kuidagi nii eraldama, et see saab netti ja NAS külge ja ongi kõik.

WiFi võrgus tolgendab vaid paar telefoni ja läpakad. "Tööjaamad" on pigem LAN otsad erinevates ruumides, kuhu saab kas PC või läpaka külge ühendada (juhul, kui WiFi'ga mingi kamm).

RT-AC68U pakub ka "guest" võrgu võimalusi, mis saab ainult netti ja ülejäänud võrku ei näe. Alguses mõtlesin, et topin TV sinna aga siis ei saaks NAS'i kätte, mis oleks nüüd võrgus B.

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
ThedEviL
HV Guru
ThedEviL

liitunud: 13.03.2003



Autoriseeritud ID-kaardiga

sõnum 19.07.2018 16:00 vasta tsitaadiga

Ot mis see loogika on, et sa lubad teleka NAS'i aga mitte kohtvõrku?
Kas sa läpakast ei tahagi midagi telekasse cast'ida?

Kui sa ikkagi tahad telekale ainult NAS'i ja internetti siis on sul vaja kahte tulemüüri reeglit:

Kõigepealt lubame nas >tv ja tv>nas
add chain=forward src-address="NAS IP" dst-address="TV IP" action=accept
add chain=forward src-address="TV IP" dst-address="NAS IP" action=accept
Nüüd dropime kõik sisevõrgust TV suunas ja suunast
add chain=forward src-address=192.168.0.0/16 dst-address="TV IP" action=drop
add chain=forward src-address="TV IP" dst-address=192.168.0.0/16 action=drop

Loogika on selles, et kui accept on tehtud, siis enam tulemüüri reegleid sellele paketile ei omistata.
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 19.07.2018 16:44 vasta tsitaadiga

ThedEviL kirjutas:
Ot mis see loogika on, et sa lubad teleka NAS'i aga mitte kohtvõrku?
Kas sa läpakast ei tahagi midagi telekasse cast'ida?...


Ma ei kujuta ette mida sealt võiks keegi tahta "cast'ida" aga miks mitte.
Tundub, et kõik ühte võrku on vist kõige valutum lahendus. Ma proovin selle nii käima saada ja kui see õnnestub, võib alati asju hiljem ringi tõsta.

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
ThedEviL
HV Guru
ThedEviL

liitunud: 13.03.2003



Autoriseeritud ID-kaardiga

sõnum 19.07.2018 17:05 vasta tsitaadiga

tsitaat:

Ma ei kujuta ette mida sealt võiks keegi tahta "cast'ida" aga miks mitte.

näed läppari või telefoni juutuubis naljakat kassivideot ja tahad seda kõigile näidata ning vajutad cast to tv nuppu
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 06.09.2018 14:11 vasta tsitaadiga

Ilmselgelt ei saa ma millelegi päris täpselt pihta saanud icon_smile.gif

Otsustasin, et meil oleks kõik üks suur võrk A


Mikrotik LAN ip on 192.168.2.1 ja IP pool nimega dhcp on 192.168.2.100-192.168.2.254

ASUS saab staatilise aadressi Mikrotik käest ja see on 192.168.2.11. Seda näitab ta kui oma WAN aadressi.

ASUS ja selle küljes olevad läpakad saavad netti kuid ASUS jagab neile välja aadresse teises subnetis 192.168.1.jne

PC, mis asub Mikrotik pordis X saab aadress 192.168.2.100, saab netti kuid ei näe ASUS't ega selle taga olevaid seadmeid.

IPTV's ma veel ei hakka isegi küsima icon_smile.gif Jõuab sinna kah. Enne tahaks kogu kola ühte võrku A saada.

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
ThedEviL
HV Guru
ThedEviL

liitunud: 13.03.2003



Autoriseeritud ID-kaardiga

sõnum 06.09.2018 15:31 vasta tsitaadiga

ära ühenda asust ja mikrotiku asuse wan pesa kaudu vaid:

Lülita asuses dhcp server välja
Määra staatiliselt asuse IP aadressiks 192.168.2.11
Ühenda see LAN pesa pidi mikrotikuga.

Valmis.

Ma ei tea milline su asuse hingeelu täpsemalt on, aga variant on ilmselt ka seadistada "bridged mode" kus asuse wan ja lan on koos.
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 06.09.2018 17:19 vasta tsitaadiga

ThedEviL kirjutas:
ära ühenda asust ja mikrotiku asuse wan pesa kaudu vaid:

Lülita asuses dhcp server välja
Määra staatiliselt asuse IP aadressiks 192.168.2.11
Ühenda see LAN pesa pidi mikrotikuga.

Valmis.

Ma ei tea milline su asuse hingeelu täpsemalt on, aga variant on ilmselt ka seadistada "bridged mode" kus asuse wan ja lan on koos.


Tundub, et see toimib :)

Tänud.

Aga see pole veel kõik. Elion IP TV on järgmine.

Kas IP TV peab olema confitud ASUS või MicroTik poolel?

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
LKits
HV Guru
LKits

liitunud: 06.09.2007



Autoriseeritud ID-kaardiga

sõnum 06.09.2018 19:19 vasta tsitaadiga

Eks kõik olenebki sellest, mis gateway ja subnet vahemik seadmetel on.

Kui Mikrotik teeb 192.168.2.0/24 (ise on GW 192.168.2.1), siis ASUS ja selle küljes olevad seadmed peavad samas vahemikus olema või peab toimuma maskeraad.
Kui terve võrk on sinu hallata, siis mina jätaks DHCP-d tegema ainult ühe seadme, pole mõtet keeruliseks ajada.

Ehk DHCP-d teeb Mikrotik, ülejäänud on kliendid ning ASUS on ka nii öelda switch. Staatilised IP-d saad määrata Mikrotik DHCP serveri poolt, static lease, siis ei teki ka manuaalselt valesti seadistamise tõttu IP konflikte.

IP TV peab olema seadistatud seadmes, kus on NAT / tulemüür, seal peab toimuma suunamised jms.

NB! Kui on oht, et võrk läheb suuremaks, soovitan võtta suurema vahemiku. Sisevõrgus pole mõtet koonerdada 253 IP-ga, võib vabalt panna ka 192.168.2.0/23 või /22 või /21
Võta appi kalkulaator - http://jodies.de/ipcalc?host=192.168.2.1&mask1=23&mask2=

Hosts/Net näitab palju erinevaid IP-sid saad jagada. Lisaks, kui on palju "jooksikuid", siis võid DHCP lease time 5 või 10 minuti peal hoida.

Aga ära liiga suureks aja, sest siis "automaatselt võrgust otsivad seadmed/funktsioonid" ei pruugi piisavalt kiiresti seadmeid leida (näiteks printerite draiverid / seadistamis-programmid).

_________________
itLahendused - Arvutite remont ja hooldus Rakveres, veebilehtede loomine, soodne veebimajutus. Võta ühendust! Tel: +372 555 268 97 ja e-post info@itlahendused.ee
tagasi üles
vaata kasutaja infot saada privaatsõnum mine selle kasutaja kodulehele
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 06.09.2018 21:08 vasta tsitaadiga

LKits, nii saigi tehtud.
Mikrotik on ainus, mis DHCP'd teeb ja LAN töötab OK ning kõik seadmed pääsevad netti. Wifi ka OK

Nagu aru saan, peaks VLAN Elion IPTV jaoks seadistama hEx pool aga vot see käib küll mul üle pea. icon_smile.gif

Mikrotik 3 pordis on Asus (port 1) ja Asus neljandas pordis on digibox.

Ehk oskab keegi hea inimene selle mulle puust ja punasena ette voolida icon_smile.gif

Tänan

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
LKits
HV Guru
LKits

liitunud: 06.09.2007



Autoriseeritud ID-kaardiga

sõnum 06.09.2018 22:06 vasta tsitaadiga

https://foorum.hinnavaatlus.ee/viewtopic.php?t=590003&highlight=
_________________
itLahendused - Arvutite remont ja hooldus Rakveres, veebilehtede loomine, soodne veebimajutus. Võta ühendust! Tel: +372 555 268 97 ja e-post info@itlahendused.ee
tagasi üles
vaata kasutaja infot saada privaatsõnum mine selle kasutaja kodulehele
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 09.09.2018 16:20 vasta tsitaadiga

LKits kirjutas:
https://foorum.hinnavaatlus.ee/viewtopic.php?t=590003&highlight=


Tänud viite eest. Panin oma IPTV mured sinna kirja.

EDIT:
Seal saadeti mind siia tagasi, sest see on seal "mikrotik ainult" teema.

Seega, lahendust endiselt pole.

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
Etz
HV Guru
Etz

liitunud: 27.01.2005



Autoriseeritud ID-kaardiga

sõnum 12.09.2018 07:53 vasta tsitaadiga

TGEgL kirjutas:
EDIT:
Seal saadeti mind siia tagasi, sest see on seal "mikrotik ainult" teema.

Seega, lahendust endiselt pole.


Ei saadetud, vaid lahendati ära, nüüd aga võiks kogu selle jutu siiski kuidagi siia teemasse saada.

_________________
...life is random...so am I...
So, there is a fan. Time to grab your sh*t, gentlemen!
tagasi üles
vaata kasutaja infot saada privaatsõnum
TGEgL
HV vaatleja

liitunud: 14.12.2013




sõnum 12.09.2018 13:05 vasta tsitaadiga

Lahendus on selline:

Siin on export rcs.
See teeb sulle Elion -> ether1 Mikrotik, selles ether4 -> AP WAN porti, ja mul on digibox AP LAN4 otsas.
Kõik muu võrgus tolgendav saab IP Mikrotik DHCP käest.


# sep/12/2018 13:45:57 by RouterOS 6.42.7
# software id = QN4F-K5V5
#
# model = RouterBOARD 750G r3
# serial number = 8A90210E

/interface bridge
add igmp-snooping=yes name=LAN protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
/interface vlan
add comment=IPTV interface=ether1 name=eth1.4 vlan-id=4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp-pool ranges=192.168.1.100-192.168.2.254
/ip dhcp-server
add address-pool=dhcp-pool disabled=no interface=LAN name=dhcp-server
/interface bridge port
add bridge=LAN interface=ether2
add bridge=LAN interface=ether3
add bridge=LAN interface=ether4
add bridge=LAN interface=ether5
/interface bridge settings
set allow-fast-path=no use-ip-firewall=yes
/ip firewall connection tracking
set enabled=yes
/ip neighbor discovery-settings
set discover-interface-list=*2000011
/ip address
add address=192.168.2.1/24 interface=LAN network=192.168.2.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    ether1
add add-default-route=special-classless default-route-distance=60 \
    dhcp-options=hostname,clientid disabled=no interface=eth1.4
/ip dhcp-server lease

### - asenda XX:XX:XX:XX:XX:XX

add address=192.168.2.254 client-id=X:XX:XX:fX:XX:XX:X comment=AP \
    mac-address=XX:XX:XX:XX:XX:XX server=dhcp-server
add address=192.168.2.250 mac-address=XX:XX:XX:XX:XX:XX server=dhcp-server
add address=192.168.2.247 client-id=XX:XX:XX:XX:XX:XX mac-address=\
    XX:XX:XX:XX:XX:XX server=dhcp-server
/ip dhcp-server network
add address=192.168.2.0/24 comment=LAN dns-server=192.168.2.1,8.8.8.8 \
    gateway=192.168.2.1
/ip dns
set servers=1.1.1.1
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=fasttrack-connection chain=forward comment="Established, Related" \
    connection-state=established,related
add action=accept chain=forward comment="Established, Related" \
    connection-state=established,related
add action=accept chain=input comment=DTV in-interface=eth1.4 protocol=igmp
add action=accept chain=input comment=DTV in-interface=eth1.4 protocol=udp
add action=accept chain=forward comment=DTV in-interface=eth1.4
add action=accept chain=input comment=Winbox disabled=yes dst-port=8291 \
    protocol=tcp
add action=accept chain=forward comment="Established, Related" \
    connection-state=established,related
add action=drop chain=output out-interface=ether1 protocol=udp src-port=53
add action=drop chain=forward in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment=NAT src-address=192.168.2.0/24 \
    to-addresses=0.0.0.0
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.2.0/24
set api disabled=yes
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=10s query-response-interval=30s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=10.0.0.0/18 interface=eth1.4 upstream=yes
add interface=LAN
/system clock
set time-zone-name=Europe/Tallinn
/system routerboard settings
set silent-boot=no


Kui see on abiks, siis tänage AgentDeus beer_yum.gif

_________________
Microsoft - Riigi sponsoreeritud ametlik nuhkvara tootja.
tagasi üles
vaata kasutaja infot saada privaatsõnum
näita postitusi alates eelmisest:   
uus teema   vasta Hinnavaatlus »  Serverid / Andmemassiivid / Tulemüürid »  vajaks abi kahe LAN (subnet?) võrgu sidumisel + NAS jagamine + IP TV
[vaata eelmist teemat] [vaata järgmist teemat]
 lisa lemmikuks
näita foorumit:  
 ignoreeri teemat 
sa ei või postitada uusi teemasid siia foorumisse
sa ei või vastata selle foorumi teemadele
sa ei või muuta oma postitusi selles foorumis
sa ei või kustutada oma postitusi selles foorumis
sa ei või vastata küsitlustele selles foorumis
sa ei saa lisada manuseid selles foorumis
sa võid manuseid alla laadida selles foorumis



Hinnavaatlus ei vastuta foorumis tehtud postituste eest.